Mimi Framework

Update Failed for MimiFUND

At the Julia Pkg REPL: I updated the packages with: pkg> update.
Julia v. 1.2 gave an error message. So I repeated update. No error.
Then in Notebook, I ran:
using Mimi
using MimiFUND #downloaded 2020-04-05

This produced these errors:
┌ Info: Precompiling MimiFUND [b3ba11de-429f-11e9-29f7-cb478ab96e7c]
└ @ Base loading.jl:1242
ERROR: LoadError: LoadError: UndefVarError: Simulation not defined
Stacktrace:
[1] top-level scope at C:\Users\Ken.julia\packages\MimiFUND\b4dFo\src\montecarlo\run_fund_scc_mcs.jl:3
[2] include at .\boot.jl:328 [inlined]
[3] include_relative(::Module, ::String) at .\loading.jl:1094
[4] include at .\Base.jl:31 [inlined]
[5] include(::String) at C:\Users\Ken.julia\packages\MimiFUND\b4dFo\src\MimiFUND.jl:1
[6] top-level scope at C:\Users\Ken.julia\packages\MimiFUND\b4dFo\src\MimiFUND.jl:11

and a few more lines. This suggests Mimi updated fine by MimiFUND didn’t.
The files at the path of line [1] and line [6] have the new date of 2020-11-28 in file explorer, so MimiFUND seems to have updated but doesn’t now work. The FUND overview page on Github say " You need to install Julia 1.1.0 or newer to run this model." so I assume it should work with Julia v.1.2.
Can you suggest how best to fix this?

In Julia 1.2 I also run pkg>add MimiFUND. But using MimiFUND gave the same errors. So I upgraded to Julia v.1.5.3 and now using MimiFUND runs properly. Does MimiFUND require a version of Julia higher than Julia 1.2?

Hi @KGregory, sorry for any confusion, it seems you have solved the problem but I will update the FUND documentation to clarify things. As you noticed, Mimi now requires Julia version 1.4 or higher, so using the most up to date version of FUND also needs Julia 1.4.

The specific error message you cite refers to an update made in Mimi, so I think your system had a version of FUND the required a higher version of Mimi, but that was blocked from downloading since you had a lower Julia version. I’m more than happy to look further into your specific case if that helps, but for now your ideal environment would be Julia v1.4 (or higher) with:

pkg> st

Status `~/.julia/environments/test/Project.toml`
  [e4e893b0] Mimi v1.1.1
  [b3ba11de] MimiFUND v3.12.0